CVE-2023-39928

NameCVE-2023-39928
DescriptionA use-after-free vulnerability exists in the MediaRecorder API of Webkit WebKitGTK 2.40.5. A specially crafted web page can abuse this vulnerability to cause memory corruption and potentially arbitrary code execution. A user would need to to visit a malicious webpage to trigger this vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5527-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
webkit2gtk (PTS)buster2.36.4-1~deb10u1vulnerable
buster (security)2.38.6-0+deb10u1vulnerable
bullseye2.42.2-1~deb11u1fixed
bullseye (security)2.44.2-1~deb11u1fixed
bookworm2.42.2-1~deb12u1fixed
bookworm (security)2.44.2-1~deb12u1fixed
sid, trixie2.44.2-1fixed
wpewebkit (PTS)bullseye (security), bullseye2.38.6-1~deb11u1vulnerable
bookworm2.38.6-1vulnerable
sid, trixie2.44.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
webkit2gtksourcebuster(unfixed)end-of-life
webkit2gtksourcebullseye2.42.1-1~deb11u1DSA-5527-1
webkit2gtksourcebookworm2.42.1-1~deb12u1DSA-5527-1
webkit2gtksource(unstable)2.42.0-1
wpewebkitsource(unstable)2.42.0-1

Notes

[buster] - webkit2gtk <end-of-life> (EOL in buster LTS)
[bookworm] - wpewebkit <ignored> (wpewebkit not covered by security support in Bookworm)
[bullseye] - wpewebkit <ignored> (wpewebkit >= 2.40 can no longer be sensibly backported)
https://webkitgtk.org/security/WSA-2023-0009.html

Search for package or bug name: Reporting problems