CVE-2023-40547

NameCVE-2023-40547
DescriptionA remote code execution vulnerability was found in Shim. The Shim boot support trusts attacker-controlled values when parsing an HTTP response. This flaw allows an attacker to craft a specific malicious HTTP request, leading to a completely controlled out-of-bounds write primitive and complete system compromise. This flaw is only exploitable during the early boot phase, an attacker needs to perform a Man-in-the-Middle or compromise the boot server to be able to exploit this vulnerability successfully.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3813-1
Debian Bugs1061519

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
shim (PTS)buster15.4-7~deb10u1vulnerable
buster (security)15.8-1~deb10u1fixed
bullseye15.7-1~deb11u1vulnerable
trixie, bookworm15.7-1vulnerable
sid15.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
shimsourcebuster15.8-1~deb10u1DLA-3813-1
shimsource(unstable)15.8-11061519

Notes

[bookworm] - shim <no-dsa> (Minor issue, fix with a point release)
[bullseye] - shim <no-dsa> (Minor issue, fix with a point release)
https://bugzilla.redhat.com/show_bug.cgi?id=2234589
https://github.com/rhboot/shim/commit/0226b56513b2b8bd5fd281bce77c40c9bf07c66d (15.8)

Search for package or bug name: Reporting problems