CVE-2023-40549

NameCVE-2023-40549
DescriptionAn out-of-bounds read flaw was found in Shim due to the lack of proper boundary verification during the load of a PE binary. This flaw allows an attacker to load a crafted PE binary, triggering the issue and crashing Shim, resulting in a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3813-1
Debian Bugs1061519

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
shim (PTS)bullseye15.7-1~deb11u1vulnerable
bookworm, trixie15.7-1vulnerable
sid15.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
shimsourcebuster15.8-1~deb10u1DLA-3813-1
shimsource(unstable)15.8-11061519

Notes

[bookworm] - shim <no-dsa> (Minor issue, fix with a point release)
[bullseye] - shim <no-dsa> (Minor issue, fix with a point release)
https://bugzilla.redhat.com/show_bug.cgi?id=2241797
https://github.com/rhboot/shim/commit/afdc5039de0a4a3a40162a32daa070f94a883f09 (15.8)

Search for package or bug name: Reporting problems