DescriptionAn issue was discovered in PostCSS before 8.4.31. The vulnerability affects linters using PostCSS to parse external untrusted CSS. An attacker can prepare CSS in such a way that it will contains parts parsed by PostCSS as a CSS comment. After processing by PostCSS, it will be included in the PostCSS output in CSS nodes (rules, properties) despite being included in a comment.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1053282

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-postcss (PTS)buster6.0.23-1vulnerable
sid, trixie8.4.31+~cs8.0.26-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[bookworm] - node-postcss <no-dsa> (Minor issue)
[bullseye] - node-postcss <no-dsa> (Minor issue)
[buster] - node-postcss <postponed> (Minor issue) (8.4.31)

Search for package or bug name: Reporting problems