CVE-2023-45362

NameCVE-2023-45362
DescriptionAn issue was discovered in DifferenceEngine.php in MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. diff-multi-sameuser (aka "X intermediate revisions by the same user not shown") ignores username suppression. This is an information leak.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3671-1, DSA-5520-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)buster1:1.31.16-1+deb10u2vulnerable
buster (security)1:1.31.16-1+deb10u7fixed
bullseye1:1.35.13-1~deb11u1fixed
bullseye (security)1:1.35.13-1+deb11u2fixed
bookworm1:1.39.5-1~deb12u1fixed
bookworm (security)1:1.39.7-1~deb12u1fixed
sid, trixie1:1.39.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisourcebuster1:1.31.16-1+deb10u7DLA-3671-1
mediawikisourcebullseye1:1.35.13-1~deb11u1DSA-5520-1
mediawikisourcebookworm1:1.39.5-1~deb12u1DSA-5520-1
mediawikisource(unstable)1:1.39.5-1

Notes

https://phabricator.wikimedia.org/T341529

Search for package or bug name: Reporting problems