CVE-2023-46565

NameCVE-2023-46565
DescriptionBuffer Overflow vulnerability in osrg gobgp commit 419c50dfac578daa4d11256904d0dc182f1a9b22 allows a remote attacker to cause a denial of service via the handlingError function in pkg/server/fsm.go.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1070393

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gobgp (PTS)bullseye2.25.0-2vulnerable
bookworm3.10.0-1vulnerable
sid, trixie3.25.0-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gobgpsource(unstable)(unfixed)1070393

Notes

[bookworm] - gobgp <no-dsa> (Minor issue)
[bullseye] - gobgp <no-dsa> (Minor issue)
https://github.com/osrg/gobgp/issues/2725

Search for package or bug name: Reporting problems