CVE-2023-47992

NameCVE-2023-47992
DescriptionAn integer overflow vulnerability in FreeImageIO.cpp::_MemoryReadProc in FreeImage 3.18.0 allows attackers to obtain sensitive information, cause a denial-of-service attacks and/or run arbitrary code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1060691

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freeimage (PTS)buster3.18.0+ds2-1+deb10u1vulnerable
buster (security)3.18.0+ds2-1+deb10u2vulnerable
bullseye (security), bullseye3.18.0+ds2-6+deb11u1vulnerable
bookworm, bookworm (security)3.18.0+ds2-9+deb12u1vulnerable
trixie, sid3.18.0+ds2-10vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freeimagesource(unstable)(unfixed)1060691

Notes

[bookworm] - freeimage <postponed> (Revisit when fixed upstream)
[bullseye] - freeimage <postponed> (Revisit when fixed upstream)
[buster] - freeimage <postponed> (Revisit when fixed upstream)
https://github.com/thelastede/FreeImage-cve-poc/tree/master/CVE-2023-47992

Search for package or bug name: Reporting problems