CVE-2023-48230

NameCVE-2023-48230
DescriptionCap'n Proto is a data interchange format and capability-based RPC system. In versions 1.0 and 1.0.1, when using the KJ HTTP library with WebSocket compression enabled, a buffer underrun can be caused by a remote peer. The underrun always writes a constant value that is not attacker-controlled, likely resulting in a crash, enabling a remote denial-of-service attack. Most Cap'n Proto and KJ users are unlikely to have this functionality enabled and so unlikely to be affected. Maintainers suspect only the Cloudflare Workers Runtime is affected. If KJ HTTP is used with WebSocket compression enabled, a malicious peer may be able to cause a buffer underrun on a heap-allocated buffer. KJ HTTP is an optional library bundled with Cap'n Proto, but is not directly used by Cap'n Proto. WebSocket compression is disabled by default. It must be enabled via a setting passed to the KJ HTTP library via `HttpClientSettings` or `HttpServerSettings`. The bytes written out-of-bounds are always a specific constant 4-byte string `{ 0x00, 0x00, 0xFF, 0xFF }`. Because this string is not controlled by the attacker, maintainers believe it is unlikely that remote code execution is possible. However, it cannot be ruled out. This functionality first appeared in Cap'n Proto 1.0. Previous versions are not affected. This issue is fixed in Cap'n Proto 1.0.1.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1056615

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
capnproto (PTS)buster0.7.0-3fixed
bullseye0.7.0-7fixed
bookworm0.9.2-2fixed
sid, trixie1.0.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
capnprotosourcebuster(not affected)
capnprotosourcebullseye(not affected)
capnprotosourcebookworm(not affected)
capnprotosource(unstable)1.0.1-31056615

Notes

[bookworm] - capnproto <not-affected> (Vulnerable code not present)
[bullseye] - capnproto <not-affected> (Vulnerable code not present)
[buster] - capnproto <not-affected> (Vulnerable code not present)
https://github.com/capnproto/capnproto/security/advisories/GHSA-r89h-f468-62w3
https://github.com/capnproto/capnproto/commit/75c5c1499aa6e7690b741204ff9af91cce526c59 (v2-branch)
https://github.com/capnproto/capnproto/commit/5d5d734b0350c6f2e36c3155753e6a19fbfeda9a (v1.0.1.1)

Search for package or bug name: Reporting problems