CVE-2023-51441

NameCVE-2023-51441
Description** UNSUPPORTED WHEN ASSIGNED ** Improper Input Validation vulnerability in Apache Axis allowed users with access to the admin service to perform possible SSRF This issue affects Apache Axis: through 1.3. As Axis 1 has been EOL we recommend you migrate to a different SOAP engine, such as Apache Axis 2/Java. Alternatively you could use a build of Axis with the patch from https://github.com/apache/axis-axis1-java/commit/685c309febc64aa393b2d64a05f90e7eb9f73e06 applied. The Apache Axis project does not expect to create an Axis 1.x release fixing this problem, though contributors that would like to work towards this are welcome.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1060169

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
axis (PTS)buster1.4-28vulnerable
buster (security)1.4-28+deb10u1vulnerable
bullseye1.4-28+deb11u1vulnerable
bookworm1.4-28+deb12u1vulnerable
trixie, sid1.4-29vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
axissource(unstable)(unfixed)1060169

Notes

[bookworm] - axis <no-dsa> (Minor issue)
[bullseye] - axis <no-dsa> (Minor issue)
[buster] - axis <no-dsa> (Minor issue)
https://www.openwall.com/lists/oss-security/2024/01/05/2
Fixed by: https://github.com/apache/axis-axis1-java/commit/685c309febc64aa393b2d64a05f90e7eb9f73e06

Search for package or bug name: Reporting problems