CVE-2023-51885

NameCVE-2023-51885
DescriptionBuffer Overflow vulnerability in Mathtex v.1.05 and before allows a remote attacker to execute arbitrary code via the length of the LaTeX string component.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1061520

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mathtex (PTS)buster, bullseye1.03-1vulnerable
bookworm1.03-1.1vulnerable
trixie, sid1.03-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mathtexsource(unstable)(unfixed)1061520

Notes

[bookworm] - mathtex <no-dsa> (Minor issue)
[bullseye] - mathtex <no-dsa> (Minor issue)
[buster] - mathtex <postponed> (Minor issue)
https://blog.yulun.ac.cn/posts/2023/fuzzing-mathtex/

Search for package or bug name: Reporting problems