CVE-2024-1681

NameCVE-2024-1681
Descriptioncorydolphin/flask-cors is vulnerable to log injection when the log level is set to debug. An attacker can inject fake log entries into the log file by sending a specially crafted GET request containing a CRLF sequence in the request path. This vulnerability allows attackers to corrupt log files, potentially covering tracks of other attacks, confusing log post-processing tools, and forging log entries. The issue is due to improper output neutralization for logs.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1069764

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-flask-cors (PTS)buster, buster (security)3.0.7-1+deb10u1vulnerable
bullseye3.0.9-2vulnerable
bookworm3.0.10-2vulnerable
sid, trixie4.0.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-flask-corssource(unstable)4.0.1-11069764

Notes

[bookworm] - python-flask-cors <no-dsa> (Minor issue)
[bullseye] - python-flask-cors <no-dsa> (Minor issue)
[buster] - python-flask-cors <postponed> (Minor issue)
https://huntr.com/bounties/25a7a0ba-9fa2-4777-acb6-03e5539bb644
https://github.com/corydolphin/flask-cors/issues/349
Fixed by: https://github.com/corydolphin/flask-cors/commit/6172c2000dba965fedb8e9a8a916ad56f0fb2630 (4.0.1)

Search for package or bug name: Reporting problems