CVE-2024-21096

NameCVE-2024-21096
DescriptionVulnerability in the MySQL Server product of Oracle MySQL (component: Client: mysqldump). Supported versions that are affected are 8.0.36 and prior and 8.3.0 and prior. Difficult to exploit vulnerability allows unauthenticated attacker with logon to the infrastructure where MySQL Server executes to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of MySQL Server accessible data as well as unauthorized read access to a subset of MySQL Server accessible data and unauthorized ability to cause a partial denial of service (partial DOS) of MySQL Server. CVSS 3.1 Base Score 4.9 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1069189

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mariadb (PTS)bookworm1:10.11.6-0+deb12u1vulnerable
sid, trixie1:10.11.8-1fixed
mariadb-10.3 (PTS)buster1:10.3.34-0+deb10u1vulnerable
buster (security)1:10.3.39-0+deb10u2vulnerable
mariadb-10.5 (PTS)bullseye1:10.5.23-0+deb11u1vulnerable
mysql-8.0 (PTS)sid8.0.37-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mariadbsource(unstable)1:10.11.8-1
mariadb-10.3source(unstable)(unfixed)
mariadb-10.5source(unstable)(unfixed)
mysql-8.0source(unstable)8.0.37-11069189

Notes

[bookworm] - mariadb <no-dsa> (Minor issue)
[bullseye] - mariadb-10.5 <no-dsa> (Minor issue)
MariaDB: Fixed in 11.2.4, 11.1.5, 11.0.6, 10.11.8, 10.6.18 and 10.5.25

Search for package or bug name: Reporting problems