CVE-2024-22725

NameCVE-2024-22725
DescriptionOrthanc versions before 1.12.2 are affected by a reflected cross-site scripting (XSS) vulnerability. The vulnerability was present in the server's error reporting.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
orthanc (PTS)buster1.5.6+dfsg-1vulnerable
buster (security)1.5.6+dfsg-1+deb10u1vulnerable
bullseye (security), bullseye1.9.2+really1.9.1+dfsg-1+deb11u1vulnerable
bookworm, bookworm (security)1.10.1+dfsg-2+deb12u1vulnerable
trixie1.12.2+dfsg-1fixed
sid1.12.3+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
orthancsource(unstable)1.12.2+dfsg-1

Notes

[bookworm] - orthanc <no-dsa> (Minor issue)
[bullseye] - orthanc <no-dsa> (Minor issue)
[buster] - orthanc <postponed> (Minor issue, XSS)
https://orthanc.uclouvain.be/hg/orthanc/rev/505416b269a0

Search for package or bug name: Reporting problems