CVE-2024-23222

NameCVE-2024-23222
DescriptionA type confusion issue was addressed with improved checks. This issue is fixed in tvOS 17.3, iOS 17.3 and iPadOS 17.3, macOS Sonoma 14.3, iOS 16.7.5 and iPadOS 16.7.5, Safari 17.3, macOS Ventura 13.6.4, macOS Monterey 12.7.3, visionOS 1.0.2. Processing maliciously crafted web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been exploited.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5618-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
webkit2gtk (PTS)buster2.36.4-1~deb10u1vulnerable
buster (security)2.38.6-0+deb10u1vulnerable
bullseye2.42.2-1~deb11u1vulnerable
bullseye (security)2.42.5-1~deb11u1fixed
bookworm2.42.2-1~deb12u1vulnerable
bookworm (security)2.42.5-1~deb12u1fixed
sid, trixie2.42.5-1fixed
wpewebkit (PTS)bullseye (security), bullseye2.38.6-1~deb11u1vulnerable
bookworm2.38.6-1vulnerable
trixie2.42.5-1fixed
sid2.42.5-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
webkit2gtksourcebuster(unfixed)end-of-life
webkit2gtksourcebullseye2.42.5-1~deb11u1DSA-5618-1
webkit2gtksourcebookworm2.42.5-1~deb12u1DSA-5618-1
webkit2gtksource(unstable)2.42.5-1
wpewebkitsource(unstable)2.42.5-1

Notes

[buster] - webkit2gtk <end-of-life> (EOL in buster LTS)
[bookworm] - wpewebkit <ignored> (wpewebkit not covered by security support in Bookworm)
[bullseye] - wpewebkit <ignored> (wpewebkit >= 2.40 can no longer be sensibly backported)
https://webkitgtk.org/security/WSA-2024-0001.html

Search for package or bug name: Reporting problems