CVE-2024-2408

NameCVE-2024-2408
DescriptionThe openssl_private_decrypt function in PHP, when using PKCS1 padding (OPENSSL_PKCS1_PADDING, which is the default), is vulnerable to the Marvin Attack unless it is used with an OpenSSL version that includes the changes from this pull request: https://github.com/openssl/openssl/pull/13817 (rsa_pkcs1_implicit_rejection). These changes are part of OpenSSL 3.2 and have also been backported to stable versions of various Linux distributions, as well as to the PHP builds provided for Windows since the previous release. All distributors and builders should ensure that this version is used to prevent PHP from being vulnerable. PHP Windows builds for the versions 8.1.29, 8.2.20 and 8.3.8 and above include OpenSSL patches that fix the vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php7.3 (PTS)buster7.3.31-1~deb10u1vulnerable
buster (security)7.3.31-1~deb10u6vulnerable
php7.4 (PTS)bullseye7.4.33-1+deb11u4vulnerable
bullseye (security)7.4.33-1+deb11u5vulnerable
php8.2 (PTS)bookworm8.2.7-1~deb12u1vulnerable
bookworm (security)8.2.18-1~deb12u1vulnerable
sid, trixie8.2.18-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php7.3source(unstable)(unfixed)
php7.4source(unstable)(unfixed)
php8.2source(unstable)(unfixed)

Notes

https://github.com/php/php-src/security/advisories/GHSA-hh26-4ppw-5864

Search for package or bug name: Reporting problems