CVE-2024-2467

NameCVE-2024-2467
DescriptionCrypt-OpenSSL-RSA vulnerable to the Marvin Attack
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1066969

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libcrypt-openssl-rsa-perl (PTS)buster, bullseye0.31-1vulnerable
sid, trixie, bookworm0.33-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libcrypt-openssl-rsa-perlsource(unstable)(unfixed)1066969

Notes

[bookworm] - libcrypt-openssl-rsa-perl <no-dsa> (Minor issue)
[bullseye] - libcrypt-openssl-rsa-perl <no-dsa> (Minor issue)
[buster] - libcrypt-openssl-rsa-perl <postponed> (Minor issue; side-channel timing attack)
https://people.redhat.com/~hkario/marvin/
https://github.com/toddr/Crypt-OpenSSL-RSA/issues/42

Search for package or bug name: Reporting problems