CVE-2024-26369

NameCVE-2024-26369
DescriptionAn issue in the HistoryQosPolicy component of FastDDS v2.12.x, v2.11.x, v2.10.x, and v2.6.x leads to a SIGABRT (signal abort) upon receiving DataWriter's data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1067180

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
fastdds (PTS)bullseye (security), bullseye2.1.0+ds-9+deb11u1vulnerable
bookworm, bookworm (security)2.9.1+ds-1+deb12u2vulnerable
sid2.14.0+ds-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fastddssourceexperimental2.14.0+ds-1
fastddssource(unstable)2.14.0+ds-21067180

Notes

https://github.com/eProsima/Fast-DDS/issues/4365
https://github.com/eProsima/Fast-DDS/pull/4375

Search for package or bug name: Reporting problems