CVE-2024-35176

NameCVE-2024-35176
DescriptionREXML is an XML toolkit for Ruby. The REXML gem before 3.2.6 has a denial of service vulnerability when it parses an XML that has many `<`s in an attribute value. Those who need to parse untrusted XMLs may be impacted to this vulnerability. The REXML gem 3.2.7 or later include the patch to fix this vulnerability. As a workaround, don't parse untrusted XMLs.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1071626, 1071627

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby2.5 (PTS)buster2.5.5-3+deb10u4vulnerable
buster (security)2.5.5-3+deb10u6vulnerable
ruby2.7 (PTS)bullseye (security), bullseye2.7.4-1+deb11u1vulnerable
ruby3.1 (PTS)bookworm3.1.2-7vulnerable
bookworm (security)3.1.2-7+deb12u1vulnerable
sid, trixie3.1.2-8.3vulnerable
ruby3.2 (PTS)sid3.2.3-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby2.5source(unstable)(unfixed)
ruby2.7source(unstable)(unfixed)
ruby3.1source(unstable)(unfixed)1071626
ruby3.2source(unstable)(unfixed)1071627

Notes

[bookworm] - ruby3.1 <no-dsa> (Minor issue)
https://github.com/ruby/rexml/security/advisories/GHSA-vg3r-rm7w-2xgh
Fixed by: https://github.com/ruby/rexml/commit/4325835f92f3f142ebd91a3fdba4e1f1ab7f1cfb (v3.2.7)
https://www.ruby-lang.org/en/news/2024/05/16/dos-rexml-cve-2024-35176/

Search for package or bug name: Reporting problems