CVE-2024-4068

NameCVE-2024-4068
DescriptionThe NPM package `braces`, versions prior to 3.0.3, fails to limit the number of characters it can handle, which could lead to Memory Exhaustion. In `lib/parse.js,` if a malicious user sends "imbalanced braces" as input, the parsing will enter a loop, which will cause the program to start allocating heap memory without freeing it at any moment of the loop. Eventually, the JavaScript heap limit is reached, and the program will crash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1071632

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-braces (PTS)buster2.0.2-2vulnerable
bullseye3.0.2+~3.0.0-1vulnerable
bookworm3.0.2+~3.0.1-1vulnerable
sid, trixie3.0.3+~3.0.4-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-bracessource(unstable)(unfixed)1071632

Notes

[bookworm] - node-braces <no-dsa> (Minor issue)
[bullseye] - node-braces <no-dsa> (Minor issue)
[buster] - node-braces <postponed> (Minor issue)
https://github.com/micromatch/braces/issues/35

Search for package or bug name: Reporting problems