DescriptionMissing authorization in PostgreSQL built-in views pg_stats_ext and pg_stats_ext_exprs allows an unprivileged database user to read most common values and other statistics from CREATE STATISTICS commands of other users. The most common values may reveal column values the eavesdropper could not otherwise read or results of functions they cannot execute. Installing an unaffected version only fixes fresh PostgreSQL installations, namely those that are created with the initdb utility after installing that version. Current PostgreSQL installations will remain vulnerable until they follow the instructions in the release notes. Within major versions 14-16, minor versions before PostgreSQL 16.3, 15.7, and 14.12 are affected. Versions before PostgreSQL 14 are unaffected.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
postgresql-11 (PTS)buster11.16-0+deb10u1fixed
buster (security)11.22-0+deb10u2fixed
postgresql-13 (PTS)bullseye13.13-0+deb11u1fixed
bullseye (security)13.14-0+deb11u1fixed
postgresql-15 (PTS)bookworm15.5-0+deb12u1vulnerable
bookworm (security)15.6-0+deb12u1vulnerable
postgresql-16 (PTS)sid, trixie16.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-11source(unstable)(not affected)
postgresql-13source(unstable)(not affected)


[bookworm] - postgresql-15 <no-dsa> (Minor issue; can be fixed via point release)
- postgresql-13 <not-affected> (Vulnerable code not present)
- postgresql-11 <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems