CVE-2024-5206

NameCVE-2024-5206
DescriptionA sensitive data leakage vulnerability was identified in scikit-learn's TfidfVectorizer, specifically in versions up to and including 1.4.1.post1, which was fixed in version 1.5.0. The vulnerability arises from the unexpected storage of all tokens present in the training data within the `stop_words_` attribute, rather than only storing the subset of tokens required for the TF-IDF technique to function. This behavior leads to the potential leakage of sensitive information, as the `stop_words_` attribute could contain tokens that were meant to be discarded and not stored, such as passwords or keys. The impact of this vulnerability varies based on the nature of the data being processed by the vectorizer.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
scikit-learn (PTS)buster0.20.2+dfsg-6vulnerable
bullseye0.23.2-5vulnerable
bookworm1.2.1+dfsg-1vulnerable
sid, trixie1.4.2+dfsg-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
scikit-learnsource(unstable)(unfixed)

Notes

[bookworm] - scikit-learn <no-dsa> (Minor issue)
[bullseye] - scikit-learn <no-dsa> (Minor issue)
[buster] - scikit-learn <postponed> (Minor issue)
https://huntr.com/bounties/14bc0917-a85b-4106-a170-d09d5191517c
https://github.com/scikit-learn/scikit-learn/commit/70ca21f106b603b611da73012c9ade7cd8e438b8 (1.5.0rc1)

Search for package or bug name: Reporting problems