CVE-2024-5458

NameCVE-2024-5458
DescriptionIn PHP versionsĀ 8.1.* before 8.1.29, 8.2.* before 8.2.20, 8.3.* before 8.3.8, due to a code logic error, filtering functions such as filter_var when validating URLsĀ (FILTER_VALIDATE_URL) for certain types of URLs the function will result in invalid user information (username + password part of URLs) being treated as valid user information. This may lead to the downstream code accepting invalid URLs as valid and parsing them incorrectly.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1072885

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php7.3 (PTS)buster7.3.31-1~deb10u1vulnerable
buster (security)7.3.31-1~deb10u6vulnerable
php7.4 (PTS)bullseye7.4.33-1+deb11u4vulnerable
bullseye (security)7.4.33-1+deb11u5vulnerable
php8.2 (PTS)bookworm8.2.7-1~deb12u1vulnerable
bookworm (security)8.2.18-1~deb12u1vulnerable
sid, trixie8.2.18-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php7.3source(unstable)(unfixed)
php7.4source(unstable)(unfixed)
php8.2source(unstable)(unfixed)1072885

Notes

Fixed in 8.3.8, 8.2.20, 8.1.29
https://github.com/php/php-src/security/advisories/GHSA-w8qr-v226-r27w
https://github.com/php/php-src/commit/7e0e3cc820c493301409a0ce2b6ef95e0ab06b0c

Search for package or bug name: Reporting problems