CVE-2024-5742

NameCVE-2024-5742
DescriptionA vulnerability was found in GNU Nano that allows a possible privilege escalation through an insecure temporary file. If Nano is killed while editing, a file it saves to an emergency file with the permissions of the running user provides a window of opportunity for attackers to escalate privileges through a malicious symlink.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3831-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nano (PTS)buster3.2-3vulnerable
buster (security)3.2-3+deb10u1fixed
bullseye5.4-2+deb11u2vulnerable
bookworm7.2-1vulnerable
sid, trixie8.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nanosourcebuster3.2-3+deb10u1DLA-3831-1
nanosource(unstable)8.0-1

Notes

[bookworm] - nano <no-dsa> (Minor issue)
[bullseye] - nano <no-dsa> (Minor issue)
Introduced by: https://git.savannah.gnu.org/cgit/nano.git/commit/?id=123110c5dc3e0d8c60a4ff0121056e301f503706 (v2.1.99pre2)
Fixed by: https://git.savannah.gnu.org/cgit/nano.git/commit/?id=5e7a3c2e7e118c7f12d5dfda9f9140f638976aa2 (v8.0)

Search for package or bug name: Reporting problems