Information on source package python3.4

Available versions

ReleaseVersion
jessie3.4.2-1
jessie (security)3.4.2-1+deb8u1

Open issues

BugjessieDescription
CVE-2019-5010vulnerableNULL pointer dereference using a specially crafted X509 certificate
CVE-2018-20406vulnerableModules/_pickle.c in Python before 3.7.1 has an integer overflow via a ...
CVE-2018-14647vulnerable (no DSA, postponed)Python's elementtree C accelerator failed to initialise Expat's hash ...
CVE-2016-5699vulnerable (no DSA)CRLF injection vulnerability in the HTTPConnection.putheader function ...
CVE-2016-5636vulnerable (no DSA)Integer overflow in the get_data function in zipimport.c in CPython ...
CVE-2016-0772vulnerable (no DSA)The smtplib library in CPython (aka Python) before 2.7.12, 3.x before ...
CVE-2014-9365vulnerable (no DSA)The HTTP clients in the (1) httplib, (2) urllib, (3) urllib2, and (4) ...
CVE-2013-1753vulnerable (no DSA)

Open unimportant issues

BugjessieDescription
CVE-2017-17522vulnerable** DISPUTED ** Lib/webbrowser.py in Python through 3.6.3 does not ...
CVE-2016-1000110vulnerable

Resolved issues

BugDescription
CVE-2018-1061python before versions 2.7.15, 3.4.9, 3.5.6rc1, 3.6.5rc1 and 3.7.0 is ...
CVE-2018-1060python before versions 2.7.15, 3.4.9, 3.5.6rc1, 3.6.5rc1 and 3.7.0 is ...
CVE-2018-1000802Python Software Foundation Python (CPython) version 2.7 contains a ...
CVE-2018-1000117Python Software Foundation CPython version From 3.2 until 3.6.4 on ...
CVE-2018-1000030Python 2.7.14 is vulnerable to a Heap-Buffer-Overflow as well as a ...
CVE-2017-1000158CPython (aka Python) up to 2.7.13 is vulnerable to an integer overflow ...
CVE-2014-4650
CVE-2014-4616Array index error in the scanstring function in the _json module in ...
CVE-2014-2667Race condition in the _get_masked_mode function in Lib/os.py in Python ...
CVE-2014-1912Buffer overflow in the socket.recvfrom_into function in ...
CVE-2013-7440The ssl.match_hostname function in CPython (aka Python) before 2.7.9 ...
CVE-2013-7338Python before 3.3.4 RC1 allows remote attackers to cause a denial of ...
CVE-2013-7040Python 2.7 before 3.4 only uses the last eight bits of the prefix to ...
CVE-2013-1752

Security announcements

DSA / DLADescription
DLA-1520-1python3.4 - security update

Search for package or bug name: Reporting problems