CVE-2004-0911

NameCVE-2004-0911
Descriptiontelnetd for netkit 0.17 and earlier, and possibly other versions, on Debian GNU/Linux allows remote attackers to cause a denial of service (free of an invalid pointer), a different vulnerability than CVE-2001-0554.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-556-1, DSA-569-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
netkit-telnet (PTS)wheezy, jessie0.17-36fixed
buster, stretch, sid0.17-41fixed
netkit-telnet-ssl (PTS)wheezy0.17.24+0.1-23fixed
jessie0.17.24+0.1-24fixed
buster, stretch, sid0.17.41+0.2-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
netkit-telnetsource(unstable)0.17-26medium
netkit-telnetsourcewoody0.17-18woody2mediumDSA-556-1
netkit-telnet-sslsource(unstable)0.17.24+0.1-4medium
netkit-telnet-sslsourcewoody0.17.17+0.1-2woody2mediumDSA-569-1

Search for package or bug name: Reporting problems