CVE-2005-0469

NameCVE-2005-0469
DescriptionBuffer overflow in the slc_add_reply function in various BSD-based Telnet clients, when handling LINEMODE suboptions, allows remote attackers to execute arbitrary code via a reply with a large number of Set Local Character (SLC) commands.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-697-1, DSA-699-1, DSA-703-1, DSA-731-1, DSA-765-1
NVD severityhigh (attack range: remote)
Debian Bugs302036, 306141
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
heimdal (PTS)squeeze (security), squeeze1.4.0~git20100726.dfsg.1-2+squeeze1fixed
wheezy1.6~git20120403+dfsg1-2fixed
jessie, sid1.6~rc2+dfsg-9fixed
krb5 (PTS)squeeze (security), squeeze1.8.3+dfsg-4squeeze7fixed
squeeze (lts)1.8.3+dfsg-4squeeze9fixed
wheezy1.10.1+dfsg-5+deb7u2fixed
wheezy (security)1.10.1+dfsg-5+deb7u3fixed
jessie, sid1.12.1+dfsg-18fixed
netkit-telnet (PTS)jessie, sid, wheezy, squeeze0.17-36fixed
netkit-telnet-ssl (PTS)squeeze0.17.24+0.1-22fixed
wheezy0.17.24+0.1-23fixed
jessie, sid0.17.24+0.1-24fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
heimdalsource(unstable)0.6.3-10high
heimdalsourcewoody0.4e-7.woody.11mediumDSA-765-1
krb4source(unstable)1.2.2-11.2high306141
krb4sourcewoody1.1-8-2.4highDSA-731-1
krb5source(unstable)1.3.6-2high
krb5sourcewoody1.2.4-5woody8highDSA-703-1
netkit-telnetsource(unstable)0.17-28high
netkit-telnetsourcewoody0.17-18woody3highDSA-697-1
netkit-telnet-sslsource(unstable)0.17.24+0.1-7.1high302036
netkit-telnet-sslsourcewoody0.17.17+0.1-2woody4highDSA-699-1

Search for package or bug name: Reporting problems