CVE-2005-0638

NameCVE-2005-0638
Descriptionxloadimage before 4.1-r2, and xli before 1.17, allows attackers to execute arbitrary commands via shell metacharacters in filenames for compressed images, which are not properly quoted when calling the gunzip command.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-694-1, DSA-695-1
NVD severityhigh (attack range: remote)
Debian Bugs298926
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xli (PTS)squeeze1.17.0+20061110-3fixed
sid, jessie, wheezy1.17.0+20061110-4fixed
xloadimage (PTS)squeeze4.1-16.1fixed
wheezy4.1-19fixed
sid, jessie4.1-23fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xlisource(unstable)1.17.0-18high
xlisourcewoody1.17.0-11woody1highDSA-695-1
xloadimagesource(unstable)4.1-14.1high298926
xloadimagesourcewoody4.1-10woody1highDSA-694-1

Search for package or bug name: Reporting problems