CVE-2005-0639

NameCVE-2005-0639
DescriptionMultiple vulnerabilities in xli before 1.17 may allow remote attackers to execute arbitrary code via "buffer management errors" from certain image properties, some of which may be related to integer overflows in PPM files.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-694-1, DSA-695-1
NVD severityhigh (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xli (PTS)squeeze1.17.0+20061110-3fixed
jessie, sid, wheezy1.17.0+20061110-4fixed
xloadimage (PTS)squeeze4.1-16.1fixed
wheezy4.1-19fixed
jessie, sid4.1-23fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xlisource(unstable)1.17.0-17high
xlisourcewoody1.17.0-11woody1highDSA-695-1
xloadimagesource(unstable)4.1-14.2high
xloadimagesourcewoody4.1-10woody1highDSA-694-1

Search for package or bug name: Reporting problems