CVE-2005-1127

NameCVE-2005-1127
DescriptionFormat string vulnerability in the log function in Net::Server 0.87 and earlier, as used in Postfix Greylisting Policy Server (Postgrey) 1.18 and earlier, and possibly other products, allows remote attackers to cause a denial of service (crash) via format string specifiers that are not properly handled before being sent to syslog, as demonstrated using sender addresses to Postgrey.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1121, DSA-1122
NVD severitymedium (attack range: remote)
Debian Bugs378640
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libnet-server-perl (PTS)squeeze0.97-1fixed
wheezy2.006-1+deb7u1fixed
stretch, sid, jessie2.008-1fixed
postgrey (PTS)squeeze1.32-6.1fixed
wheezy1.34-1.1fixed
stretch, sid, jessie1.35-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libnet-server-perlsource(unstable)0.89-1medium378640
libnet-server-perlsourcesarge0.87-3sarge1mediumDSA-1122
postgreysource(unstable)1.22-1medium
postgreysourcesarge1.21-1sarge1mediumDSA-1121

Notes

Net::Server was already fixed in 0.87-1, although the changelog doesn't mention
the security implication, which was noticed later. I've verified both fixes
are identical
but DSA-1122 thinks it was fixed in 0.89-1, so mark that version to make
scripts happy (at time of writing, 0.90-1 is in testing)

Search for package or bug name: Reporting problems