CVE-2005-2491

NameCVE-2005-2491
DescriptionInteger overflow in pcre_compile.c in Perl Compatible Regular Expressions (PCRE) before 6.2, as used in multiple products such as Python, Ethereal, and PHP, allows attackers to execute arbitrary code via quantifier values in regular expressions, which leads to a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-800-1, DSA-817-1, DSA-819-1, DSA-821-1, DTSA-10-1
NVD severityhigh (attack range: remote)
Debian Bugs324531, 326628, 326898

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnumeric (PTS)wheezy1.10.17-1.1fixed
jessie1.12.18-2fixed
stretch1.12.32-1fixed
buster, sid1.12.35-1fixed
goffice (PTS)wheezy0.8.17-1.2fixed
jessie0.10.18-1fixed
stretch0.10.32-1.1fixed
buster, sid0.10.35-1fixed
pcre3 (PTS)wheezy1:8.30-5fixed
jessie2:8.35-3.3+deb8u4fixed
stretch2:8.39-3fixed
buster, sid2:8.39-8fixed
vfu (PTS)wheezy, jessie, stretch4.10-1.1fixed
buster, sid4.16+repack-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnumericsource(unstable)1.5.1-1unimportant326628, 326898
gofficesource(unstable)0.1.0-3unimportant326898
pcre3source(unstable)6.3-1medium324531
pcre3sourceetch6.3-0.1etch1highDTSA-10-1
pcre3sourcesarge4.5-1.2sarge1highDSA-800-1
pcre3sourcewoody3.4-1.1woody1highDSA-800-1
python2.1source(unstable)2.1.3dfsg-3medium
python2.1sourcesarge2.1.3dfsg-1sarge1mediumDSA-819-1
python2.1sourcewoody2.1.3-3.4mediumDSA-819-1
python2.2source(unstable)2.2.3dfsg-4medium
python2.2sourcesarge2.2.3dfsg-2sarge1mediumDSA-817-1324531
python2.2sourcewoody2.2.1-4.8mediumDSA-817-1324531
python2.3source(unstable)2.3.5-8medium
python2.3sourcesarge2.3.5-3sarge1mediumDSA-821-1
vfusource(unstable)(not affected)

Notes

- vfu <not-affected> (does not include the vulnerable part of pcre)
gnumeric/goffice includes one as well; not exploitable as affected code not used

Search for package or bug name: Reporting problems