CVE-2005-3534

NameCVE-2005-3534
DescriptionBuffer overflow in the Network Block Device (nbd) server 2.7.5 and earlier, and 2.8.0 through 2.8.2, allows remote attackers to execute arbitrary code via a large request, which is written past the end of the buffer because nbd does not account for memory taken by the reply header.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-924-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nbd (PTS)squeeze, squeeze (security)1:2.9.16-8+squeeze1fixed
squeeze (lts)1:2.9.16-8+squeeze2fixed
wheezy1:3.2-4~deb7u4fixed
wheezy (security)1:3.2-4~deb7u5fixed
jessie1:3.8-4fixed
jessie (security)1:3.8-4+deb8u1fixed
stretch, sid1:3.10-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nbdsource(unstable)1:2.8.3-1high
nbdsourcesarge1:2.7.3-3sarge1highDSA-924-1
nbdsourcewoody1.2cvs20020320-3.woody.3highDSA-924-1

Search for package or bug name: Reporting problems