CVE-2006-4513

NameCVE-2006-4513
DescriptionMultiple integer overflows in the WV library in wvWare (formerly mswordview) before 1.2.3, as used by AbiWord, KWord, and possibly other products, allow user-assisted remote attackers to execute arbitrary code via a crafted Microsoft Word (DOC) file that produces (1) large LFO clfolvl values in the wvGetLFO_records function or (2) a large LFO nolfo value in the wvGetFLO_PLF function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs396256, 396360

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
abiword (PTS)stretch3.0.2-2+deb9u2fixed
buster3.0.2-8fixed
bullseye3.0.4~dfsg-3fixed
bookworm, sid3.0.5~dfsg-1fixed
wv (PTS)bookworm, sid, buster, bullseye, stretch1.2.9-4.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
abiwordsourcesarge2.4.6-1.1396360
abiwordsource(unstable)2.4.6-1
wvsource(unstable)1.2.4-1medium396256

Notes

exact abiword fixed version not known, but <= 2.4.6-1

Search for package or bug name: Reporting problems