CVE-2007-0002

NameCVE-2007-0002
DescriptionMultiple heap-based buffer overflows in WordPerfect Document importer/exporter (libwpd) before 0.8.9 allow user-assisted remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a crafted WordPerfect file in which values to loop counters are not properly handled in the (1) WP3TablesGroup::_readContents and (2) WP5DefinitionGroup_DefineTablesSubGroup::WP5DefinitionGroup_DefineTablesSubGroup functions. NOTE: the integer overflow has been split into CVE-2007-1466.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1268-1, DSA-1270-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libwpd (PTS)wheezy0.9.4-3fixed
jessie0.10.0-2+deb8u1fixed
stretch0.10.1-5+deb9u1fixed
buster, sid0.10.2-2fixed
openoffice.org (PTS)wheezy1:3.4.0~ooo340m1-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libwpdsource(unstable)0.8.9-1high
libwpdsourceetch0.8.7-6high
libwpdsourcesarge0.8.1-1sarge1highDSA-1268-1
openoffice.orgsource(unstable)2.0.4.dfsg.2-6high
openoffice.orgsourceetch2.0.4.dfsg.2-5etch1high
openoffice.orgsourcesarge1.1.3-9sarge6highDSA-1270-1

Notes

openoffice.org changelog indicates libwpd is included but not used

Search for package or bug name: Reporting problems