CVE-2007-4766

NameCVE-2007-4766
DescriptionMultiple integer overflows in Perl-Compatible Regular Expression (PCRE) library before 7.3 allow context-dependent attackers to cause a denial of service (crash) or execute arbitrary code via unspecified escape (backslash) sequences.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-1399-1, DSA-1570-1, DTSA-77-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glib2.0 (PTS)buster2.58.3-2+deb10u3fixed
buster (security)2.58.3-2+deb10u6fixed
bullseye2.66.8-1+deb11u1fixed
bullseye (security)2.66.8-1+deb11u3fixed
bookworm2.74.6-2fixed
bookworm (security)2.74.6-2+deb12u2fixed
sid, trixie2.80.2-1fixed
pcre3 (PTS)buster2:8.39-12fixed
bullseye2:8.39-13fixed
sid, trixie, bookworm2:8.39-15fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
glib2.0source(unstable)2.14.3-1unimportant
kazehakasesourceetch0.4.2-1etch1DSA-1570-1
kazehakasesource(unstable)0.5.2-1
pcre3sourcesarge4.5+7.4-1DSA-1399-1
pcre3sourceetch6.7+7.4-2DSA-1399-1
pcre3sourcelenny6.7+7.4-2+lenny1DTSA-77-1
pcre3source(unstable)7.3-1

Notes

glib only embeds pcre in the udeb, no attack vector

Search for package or bug name: Reporting problems