CVE-2007-4767

NameCVE-2007-4767
DescriptionPerl-Compatible Regular Expression (PCRE) library before 7.3 does not properly compute the length of (1) a \p sequence, (2) a \P sequence, or (3) a \P{x} sequence, which allows context-dependent attackers to cause a denial of service (infinite loop or crash) or execute arbitrary code.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1399-1, DSA-1570-1, DTSA-77-1
NVD severitymedium (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glib2.0 (PTS)squeeze2.24.2-1fixed
wheezy2.33.12+really2.32.4-5fixed
jessie, sid2.42.1-1fixed
kazehakase (PTS)squeeze0.5.8-4fixed
pcre3 (PTS)squeeze8.02-1.1fixed
wheezy1:8.30-5fixed
jessie, sid2:8.35-3.3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
glib2.0source(unstable)2.14.3-1unimportant
kazehakasesource(unstable)0.5.2-1medium
kazehakasesourceetch0.4.2-1etch1mediumDSA-1570-1
pcre3source(unstable)7.3-1medium
pcre3sourceetch6.7+7.4-2mediumDSA-1399-1
pcre3sourcelenny6.7+7.4-2+lenny1mediumDTSA-77-1
pcre3sourcesarge4.5+7.4-1mediumDSA-1399-1

Notes

glib only embeds pcre in the udeb, no attack vector

Search for package or bug name: Reporting problems