CVE-2007-4768

NameCVE-2007-4768
DescriptionHeap-based buffer overflow in Perl-Compatible Regular Expression (PCRE) library before 7.3 allows context-dependent attackers to execute arbitrary code via a singleton Unicode sequence in a character class in a regex pattern, which is incorrectly optimized.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1399-1, DSA-1570-1, DTSA-77-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glib2.0 (PTS)jessie2.42.1-1fixed
jessie (security)2.42.1-1+deb8u3fixed
stretch2.50.3-2+deb9u1fixed
buster2.58.3-2+deb10u2fixed
bullseye, sid2.62.2-3fixed
pcre3 (PTS)jessie2:8.35-3.3+deb8u4fixed
stretch2:8.39-3fixed
buster, bullseye, sid2:8.39-12fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
glib2.0source(unstable)2.14.3-1unimportant
kazehakasesource(unstable)0.5.2-1
kazehakasesourceetch0.4.2-1etch1DSA-1570-1
pcre3source(unstable)7.3-1
pcre3sourceetch6.7+7.4-2DSA-1399-1
pcre3sourcelenny6.7+7.4-2+lenny1DTSA-77-1
pcre3sourcesarge4.5+7.4-1DSA-1399-1

Notes

glib only embeds pcre in the udeb, no attack vector

Search for package or bug name: Reporting problems