CVE-2007-5191

NameCVE-2007-5191
Descriptionmount and umount in util-linux and loop-aes-utils call the setuid and setgid functions in the wrong order and do not check the return values, which might allow attackers to gain privileges via helpers such as mount.nfs.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1449-1, DSA-1450-1, DTSA-64-1, DTSA-70-1
NVD severitymedium (attack range: local)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
loop-aes-utils (PTS)squeeze2.16.2-1fixed
util-linux (PTS)squeeze2.17.2-9fixed
wheezy2.20.1-5.3fixed
jessie2.25.2-6fixed
stretch, sid2.26.2-9fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
loop-aes-utilssource(unstable)2.13-2low
loop-aes-utilssourceetch2.12r-15+etch1mediumDSA-1449-1
loop-aes-utilssourcelenny2.12r-16+lenny1mediumDTSA-70-1
loop-aes-utilssourcesarge2.12p-4sarge2mediumDSA-1449-1
util-linuxsource(unstable)2.13-8low
util-linuxsourceetch2.12r-19etch1mediumDSA-1450-1
util-linuxsourcelenny2.12r-19+lenny1mediumDTSA-64-1
util-linuxsourcesarge2.12p-4sarge2mediumDSA-1450-1

Search for package or bug name: Reporting problems