CVE-2008-1686

NameCVE-2008-1686
DescriptionArray index vulnerability in Speex 1.1.12 and earlier, as used in libfishsound 0.9.0 and earlier, including Illiminable DirectShow Filters and Annodex Plugins for Firefox, xine-lib before 1.1.12, and many other products, allows remote attackers to execute arbitrary code via a header structure containing a negative offset, which is used to dereference a function pointer.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1584-1, DSA-1585-1, DSA-1586-1, DTSA-127-1, DTSA-128-1, DTSA-129-1
NVD severityhigh (attack range: remote)
Debian Bugs475152
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libfishsound (PTS)squeeze1.0.0-1fixed
wheezy1.0.0-1.1fixed
stretch, sid, jessie1.0.0-4fixed
speex (PTS)squeeze1.2~rc1-1fixed
wheezy1.2~rc1-7fixed
stretch, sid, jessie1.2~rc1.2-1fixed
xine-lib (PTS)squeeze1.1.19-2fixed
wheezy1.1.21-1+deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libfishsoundsource(unstable)0.7.0-2.2medium475152
libfishsoundsourceetch0.7.0-2etch1highDSA-1584-1
libfishsoundsourcelenny0.7.0-2.1+lenny1highDTSA-127-1
speexsource(unstable)1.2~beta2-1medium
speexsourceetch1.1.12-3etch1highDSA-1585-1
speexsourcelenny1.1.12-3+lenny1highDTSA-129-1
xine-libsource(unstable)1.1.12-1medium
xine-libsourceetch1.1.2+dfsg-7highDSA-1586-1
xine-libsourcelenny1.1.10.1-2+lenny2highDTSA-128-1

Search for package or bug name: Reporting problems