CVE-2008-4776

NameCVE-2008-4776
Descriptionlibgadu before 1.8.2 allows remote servers to cause a denial of service (crash) via a contact description with a large length, which triggers a buffer over-read.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1664-1
NVD severitymedium (attack range: remote)
Debian Bugs503916, 504429, 559782

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
centerim (PTS)wheezy4.22.10-2fixed
ekg (PTS)wheezy1:1.9~pre+r2854-1fixed
jessie1:1.9~pre+r2855-2fixed
stretch1:1.9~pre+r2855-5fixed
kadu (PTS)wheezy0.11.2-1fixed
jessie1.2-2fixed
stretch4.1-1fixed
buster, sid4.1-1.1fixed
libgadu (PTS)wheezy, wheezy (security)1:1.11.2-1+deb7u2fixed
jessie1:1.12.0-5fixed
stretch1:1.12.1-4fixed
buster, sid1:1.12.2-2fixed
qutecom (PTS)wheezy2.2.1+dfsg1-3fixed
jessie2.2.1+dfsg1-5.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
centerimsource(unstable)4.22.9-1low559782
ekgsource(unstable)1:1.8~rc0-1low
ekgsourceetch1:1.7~rc2-1etch2mediumDSA-1664-1
kadusource(unstable)0.6.0.2-3low504429
libgadusource(unstable)1:1.8.0+r592-3low503916
qutecomsource(unstable)(not affected)

Notes

[lenny] - centerim <no-dsa> (Minor issue)
claimed to be fixed in point update but is not: [lenny] - centerim 4.22.5-1+lenny1
- qutecom <not-affected> (does not use libgadu embed; bug #559784)

Search for package or bug name: Reporting problems