CVE-2009-2663

NameCVE-2009-2663
Descriptionlibvorbis before r16182, as used in Mozilla Firefox 3.5.x before 3.5.2 and other products, allows context-dependent attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via a crafted .ogg file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1939-1
NVD severityhigh
Debian Bugs540958, 540961, 669196

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvorbis (PTS)stretch1.3.5-4+deb9u2fixed
stretch (security)1.3.5-4+deb9u3fixed
buster1.3.6-2fixed
bookworm, sid, bullseye1.3.7-1fixed
libvorbisidec (PTS)stretch (security), stretch1.0.2+svn18153-1+deb9u1fixed
buster1.2.1+git20180316-3fixed
bookworm, sid, bullseye1.2.1+git20180316-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvorbissourceetch1.1.2.dfsg-1.4+etch1DSA-1939-1
libvorbissourcelenny1.2.0.dfsg-3.1+lenny1DSA-1939-1
libvorbissource(unstable)1.2.0.dfsg-6medium540958
libvorbisidecsource(unstable)1.0.2+svn16259-2669196
xulrunnersourceetch(not affected)
xulrunnersourcelenny(not affected)
xulrunnersource(unstable)1.9.1.2-1medium540961

Notes

[squeeze] - libvorbisidec <no-dsa> (Minor issue, no dev-deps)
[etch] - xulrunner <not-affected> (vulnerability introduced in 1.9.1.0)
[lenny] - xulrunner <not-affected> (vulnerability introduced in 1.9.1.0)

Search for package or bug name: Reporting problems