CVE-2009-3379

NameCVE-2009-3379
DescriptionMultiple unspecified vulnerabilities in libvorbis, as used in Mozilla Firefox 3.5.x before 3.5.4, allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via unknown vectors. NOTE: this might overlap CVE-2009-2663.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1939-1
NVD severityhigh (attack range: remote)
Debian Bugs669196

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvorbis (PTS)jessie1.3.4-2fixed
jessie (security)1.3.4-2+deb8u1fixed
stretch1.3.5-4fixed
stretch (security)1.3.5-4+deb9u2fixed
buster, sid1.3.6-1fixed
libvorbisidec (PTS)jessie1.0.2+svn18153-1~deb8u1fixed
jessie (security)1.0.2+svn18153-1~deb8u2fixed
stretch1.0.2+svn18153-1fixed
stretch (security)1.0.2+svn18153-1+deb9u1fixed
buster, sid1.2.1+git20180316-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvorbissource(unstable)1.2.3-1medium
libvorbissourceetch1.1.2.dfsg-1.4+etch1highDSA-1939-1
libvorbissourcelenny1.2.0.dfsg-3.1+lenny1highDSA-1939-1
libvorbisidecsource(unstable)1.0.2+svn18153-0.1high669196
xulrunnersource(unstable)1.9.1.4-1high
xulrunnersourceetch(not affected)
xulrunnersourcelenny(not affected)

Notes

[squeeze] - libvorbisidec <no-dsa> (Minor issue, no dev-deps)
[lenny] - xulrunner <not-affected> (Only affects Firefox 3.5)
[etch] - xulrunner <not-affected> (Only affects Firefox 3.5)

Search for package or bug name: Reporting problems