CVE-2009-3555

NameCVE-2009-3555
DescriptionThe TLS protocol, and the SSL protocol 3.0 and possibly earlier, as used in Microsoft Internet Information Services (IIS) 7.0, mod_ssl in the Apache HTTP Server 2.2.14 and earlier, OpenSSL before 0.9.8l, GnuTLS 2.8.5 and earlier, Mozilla Network Security Services (NSS) 3.12.4 and earlier, multiple Cisco products, and other products, does not properly associate renegotiation handshakes with an existing connection, which allows man-in-the-middle attackers to insert data into HTTPS sessions, and possibly other types of sessions protected by TLS or SSL, by sending an unauthenticated request that is processed retroactively by a server in a post-renegotiation context, related to a "plaintext injection" attack, aka the "Project Mogul" issue.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1934-1, DSA-2141-1, DSA-2141-2, DSA-2626-1, DSA-3253-1
NVD severitymedium (attack range: remote)
Debian Bugs704946, 765649
Debian/oldoldstablepackages pound, zorp are vulnerable.
Debian/oldstablepackage pound is vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)squeeze2.2.16-6+squeeze12fixed
squeeze (security)2.2.16-6+squeeze11fixed
squeeze (lts)2.2.16-6+squeeze15fixed
wheezy2.2.22-13+deb7u4fixed
wheezy (security)2.2.22-13+deb7u6fixed
jessie2.4.10-10fixed
jessie (security)2.4.10-10+deb8u1fixed
stretch, sid2.4.16-3fixed
gnutls26 (PTS)squeeze, squeeze (security)2.8.6-1+squeeze3fixed
squeeze (lts)2.8.6-1+squeeze5fixed
wheezy2.12.20-8+deb7u2fixed
wheezy (security)2.12.20-8+deb7u3fixed
lighttpd (PTS)squeeze, squeeze (security)1.4.28-2+squeeze1.6fixed
squeeze (lts)1.4.28-2+squeeze1.7fixed
wheezy (security), wheezy1.4.31-4+deb7u3fixed
stretch, sid, jessie1.4.35-4fixed
matrixssl (PTS)squeeze, wheezy1.8.8-1fixed
nginx (PTS)squeeze, squeeze (security)0.7.67-3+squeeze3fixed
squeeze (lts)0.7.67-3+squeeze4fixed
wheezy (security), wheezy1.2.1-2.2+wheezy3fixed
jessie1.6.2-5fixed
stretch1.9.3-1fixed
sid1.9.4-1fixed
nss (PTS)squeeze, squeeze (security)3.12.8-1+squeeze7fixed
squeeze (lts)3.12.8-1+squeeze11fixed
wheezy2:3.14.5-1+deb7u3fixed
wheezy (security)2:3.14.5-1+deb7u5fixed
jessie2:3.17.2-1.1fixed
jessie (security)2:3.17.2-1.1+deb8u1fixed
stretch, sid2:3.20-1fixed
openjdk-6 (PTS)squeeze6b18-1.8.13-0+squeeze2fixed
squeeze (security)6b31-1.13.3-1~deb6u1fixed
squeeze (lts)6b36-1.13.8-1~deb6u1fixed
wheezy6b27-1.12.5-1fixed
wheezy (security)6b36-1.13.8-1~deb7u1fixed
openssl (PTS)squeeze, squeeze (security)0.9.8o-4squeeze14fixed
squeeze (lts)0.9.8o-4squeeze21fixed
wheezy1.0.1e-2+deb7u13fixed
wheezy (security)1.0.1e-2+deb7u17fixed
jessie1.0.1k-3fixed
jessie (security)1.0.1k-3+deb8u1fixed
stretch, sid1.0.2d-1fixed
polarssl (PTS)squeeze, squeeze (security)1.2.9-1~deb6u1fixed
squeeze (lts)1.2.9-1~deb6u4fixed
wheezy1.2.9-1~deb7u4fixed
wheezy (security)1.2.9-1~deb7u5fixed
stretch, sid, jessie1.3.9-2.1fixed
pound (PTS)squeeze2.5-1vulnerable
wheezy2.6-2vulnerable
wheezy (security)2.6-2+deb7u1fixed
jessie (security), jessie2.6-6+deb8u1fixed
stretch, sid2.6-6.1fixed
sun-java6 (PTS)squeeze/non-free6.26-0squeeze1fixed
tomcat-native (PTS)squeeze1.1.20-1fixed
squeeze (lts)1.1.31-1~deb6u1fixed
wheezy1.1.24-1fixed
jessie1.1.32~repack-2fixed
stretch, sid1.1.33-1fixed
zorp (PTS)squeeze3.3.6-1.1vulnerable
jessie, wheezy3.9.5-4fixed
stretch, sid3.9.5-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2source(unstable)2.2.14-2medium
apache2sourceetch2.2.3-4+etch11mediumDSA-1934-1
apache2sourcelenny2.2.9-10+lenny6mediumDSA-1934-1
classpathsource(unstable)(unfixed)medium
gnutls26source(unstable)(not affected)
lighttpdsource(unstable)1.4.30-1medium
lighttpdsourcesqueeze1.4.28-2+squeeze1.2mediumDSA-2626-1
matrixsslsource(unstable)1.8.8-1medium
nginxsource(unstable)0.7.64-1medium
nsssource(unstable)3.12.6-1medium
nsssourcelenny3.12.3.1-0lenny3mediumDSA-2141-2
openjdk-6source(unstable)6b18-1.8.2-1medium
opensslsource(unstable)0.9.8k-6medium
opensslsourcelenny0.9.8g-15+lenny11mediumDSA-2141-1
polarsslsource(unstable)1.2.0-1medium704946
poundsource(unstable)2.6-6.1medium765649
poundsourcejessie2.6-6+deb8u1mediumDSA-3253-1
poundsourcewheezy2.6-2+deb7u1mediumDSA-3253-1
sun-java5source(unstable)(unfixed)medium
sun-java6source(unstable)6.19-1medium
sun-java6sourcelenny6-22-0lennymedium
tomcat-nativesource(unstable)1.1.18-1medium
zorpsource(unstable)3.9.2-1medium

Notes

[lenny] - sun-java5 <no-dsa> (Minor issue)
Update 22 for Sun Java implemented the new RFC extension
[lenny] - matrixssl <no-dsa> (Fringe SSL implementation, can be fixed in spu)
[lenny] - tomcat-native <no-dsa> (Minor issue)
- gnutls26 <not-affected> (safely handles renegotiation; however support for RFC 5746 would be useful)
[squeeze] - zorp <no-dsa> (Minor issue)
[lenny] - zorp <no-dsa> (Minor issue)
[jessie] - pound <no-dsa> (Minor issue)
the anti_beast.patch in pound 2.6-2 has some provision for this issue too but it seems to be broken, cf #765649
for any of the currently unfixed implementations, you can solve the problem by disabling renegotiation
the following implement RFC 5746:
- openssl 0.9.8m-1
- apache 2.2.15-1
- nss 3.12.6-1
- sun-java6 6.19-1

Search for package or bug name: Reporting problems