CVE-2010-5312

NameCVE-2010-5312
DescriptionCross-site scripting (XSS) vulnerability in jquery.ui.dialog.js in the Dialog widget in jQuery UI before 1.10.0 allows remote attackers to inject arbitrary web script or HTML via the title option.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-258-1, DSA-3249-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jqueryui (PTS)wheezy, wheezy (security)1.8.ooops.21+dfsg-2+deb7u2fixed
jessie1.10.1+dfsg-1fixed
stretch1.12.1+dfsg-4fixed
buster, sid1.12.1+dfsg-5fixed
owncloud (PTS)jessie (security)7.0.4+dfsg-4~deb8u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jqueryuisource(unstable)1.10.1+dfsg-1medium
jqueryuisourcesqueeze1.8.dfsg-3+deb6u1mediumDLA-258-1
jqueryuisourcewheezy1.8.ooops.21+dfsg-2+deb7u1mediumDSA-3249-1
owncloudsource(unstable)(not affected)

Notes

- owncloud <not-affected> (embedded copy, bug #722500, of version 1.10.1, already fixed)
http://bugs.jqueryui.com/ticket/6016
https://github.com/jquery/jquery-ui/commit/7e9060c109b928769a664dbcc2c17bd21231b6f3

Search for package or bug name: Reporting problems