DescriptionHeap-based buffer overflow in the unhtmlify function in foomatic-rip in foomatic-filters before 4.0.6 allows remote attackers to cause a denial of service (memory corruption and crash) or possibly execute arbitrary code via a long job title.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cups-filters (PTS)buster1.21.6-5fixed
bookworm, sid1.28.17-2fixed
foomatic-filters (PTS)buster4.0.17-11fixed
bookworm, sid4.0.17-16fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cups-filterssource(unstable)(not affected)


- cups-filters <not-affected> (Vulnerable code not present)
cups-filters 1.0.42 introduced foomatic-rip filter which already was fixed. (HEAD) (4.0.x branch)

Search for package or bug name: Reporting problems