CVE-2010-5325

NameCVE-2010-5325
DescriptionHeap-based buffer overflow in the unhtmlify function in foomatic-rip in foomatic-filters before 4.0.6 allows remote attackers to cause a denial of service (memory corruption and crash) or possibly execute arbitrary code via a long job title.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cups-filters (PTS)stretch, stretch (security)1.11.6-3+deb9u1fixed
buster1.21.6-5fixed
bullseye1.28.7-1fixed
bookworm, sid1.28.10-2fixed
foomatic-filters (PTS)stretch4.0.17-9fixed
buster4.0.17-11fixed
bookworm, bullseye, sid4.0.17-12fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cups-filterssource(unstable)(not affected)
foomatic-filterssource(unstable)4.0.5-6

Notes

- cups-filters <not-affected> (Vulnerable code not present)
cups-filters 1.0.42 introduced foomatic-rip filter which already was fixed.
https://bugs.linuxfoundation.org/show_bug.cgi?id=515
https://bugzilla.redhat.com/show_bug.cgi?id=1218297
http://bzr.linuxfoundation.org/loggerhead/openprinting/foomatic/foomatic-filters/revision/239 (HEAD)
http://bzr.linuxfoundation.org/loggerhead/openprinting/foomatic-4.0/foomatic-filters/revision/225 (4.0.x branch)

Search for package or bug name: Reporting problems