CVE-2011-2483

NameCVE-2011-2483
Descriptioncrypt_blowfish before 1.1, as used in PHP before 5.3.7 on certain platforms, PostgreSQL before 8.4.9, and other products, does not properly handle 8-bit characters, which makes it easier for context-dependent attackers to determine a cleartext password by leveraging knowledge of a password hash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2340-1, DSA-2399-1
NVD severitymedium (attack range: remote)
Debian Bugs631283, 631285, 631347, 679628

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libcrypt-eksblowfish-perl (PTS)wheezy0.008-1fixed
jessie0.009-1fixed
stretch, sid0.009-2fixed
libxcrypt (PTS)wheezy1:2.4-3fixed
jessie1:2.4-3.1fixed
stretch, sid1:2.4-4fixed
php-suhosin (PTS)sid0.9.33-3fixed
php5 (PTS)wheezy5.4.45-0+deb7u2fixed
wheezy (security)5.4.45-0+deb7u4fixed
jessie5.6.20+dfsg-0+deb8u1fixed
jessie (security)5.6.24+dfsg-0+deb8u1fixed
sid5.6.24+dfsg-1fixed
postgresql-8.4 (PTS)wheezy8.4.22-0+deb7u1fixed
postgresql-9.1 (PTS)wheezy9.1.21-0+deb7u1fixed
wheezy (security)9.1.23-0+deb7u1fixed
jessie9.1.22-0+deb8u1fixed
jessie (security)9.1.16-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libcrypt-eksblowfish-perlsource(unstable)(not affected)
libxcryptsource(unstable)1:2.4-1.1medium679628
php-suhosinsource(unstable)(not affected)
php-suhosinsourcelenny(unfixed)medium631283
php5source(unstable)5.3.6-13medium631347
php5sourcelenny5.2.6.dfsg.1-1+lenny14mediumDSA-2399-1
php5sourcesqueeze5.3.3-7+squeeze5mediumDSA-2399-1
postgresql-8.3sourcelenny8.3.16-0lenny1mediumDSA-2340-1
postgresql-8.4source(unstable)8.4.9-1medium631285
postgresql-8.4sourcesqueeze8.4.9-0squeeze1mediumDSA-2340-1
postgresql-9.0source(unstable)9.0.5-1medium631285
postgresql-9.1source(unstable)9.1~rc1-1medium

Notes

- libcrypt-eksblowfish-perl <not-affected> (discovered and corrected in initial release in 2007)
- php-suhosin <not-affected> (bug #631283; that portion is not used since PHP 5.3)
[squeeze] - libxcrypt <no-dsa> (Minor issue)
http://openwall.com/lists/oss-security/2011/06/20/2

Search for package or bug name: Reporting problems