CVE-2012-0444

NameCVE-2012-0444
DescriptionMozilla Firefox before 3.6.26 and 4.x through 9.0, Thunderbird before 3.1.18 and 5.0 through 9.0, and SeaMonkey before 2.7 do not properly initialize nsChildView data structures, which allows remote attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via a crafted Ogg Vorbis file.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2400-1, DSA-2402-1, DSA-2406-1, DSA-2412-1
NVD severityhigh (attack range: remote)
Debian Bugs664197, 669196
Debian/oldstablepackage libvorbisidec is vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iceape (PTS)squeeze (security)2.0.11-17fixed
icedove (PTS)squeeze (security), squeeze3.0.11-1+squeeze15fixed
wheezy31.3.0-1~deb7u1fixed
wheezy (security)31.6.0-1~deb7u1fixed
jessie, sid31.6.0-1fixed
iceweasel (PTS)squeeze (security), squeeze3.5.16-20fixed
wheezy31.3.0esr-1~deb7u1fixed
wheezy (security)31.6.0esr-1~deb7u1fixed
jessie, sid31.6.0esr-1fixed
libvorbis (PTS)squeeze (security), squeeze1.3.1-1+squeeze1fixed
wheezy1.3.2-1.3fixed
jessie, sid1.3.4-2fixed
libvorbisidec (PTS)squeeze1.0.2+svn16259-2vulnerable
jessie, sid, wheezy1.0.2+svn18153-0.2fixed
xulrunner (PTS)wheezy, wheezy (security)24.8.1esr-2~deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)2.0.14-10high
iceapesourcelenny(not affected)
iceapesourcesqueeze2.0.11-10highDSA-2402-1
icedovesource(unstable)10.0.3-1high
icedovesourcelenny(not affected)
icedovesourcesqueeze3.0.11-1+squeeze7highDSA-2406-1
iceweaselsource(unstable)10.0-1high
iceweaselsourcelenny(not affected)
iceweaselsourcesqueeze3.5.16-12highDSA-2400-1
libvorbissource(unstable)1.3.2-1.2high664197
libvorbissourcesqueeze1.3.1-1+squeeze1highDSA-2412-1
libvorbisidecsource(unstable)1.0.2+svn18153-0.1high669196
xulrunnersource(unstable)(not affected)
xulrunnersourcelenny1.9.0.19-16highDSA-2400-1

Notes

[squeeze] - libvorbisidec <no-dsa> (Minor issue, no dev-deps)
[lenny] - icedove <not-affected> (Vulnerable code not present)
- xulrunner <not-affected> (Vulnerable code not present)
[lenny] - iceweasel <not-affected> (Lenny's iceweasel uses Xulrunner from the xulrunner source pkg)
[lenny] - iceape <not-affected> (Only a stub package)

Search for package or bug name: Reporting problems