CVE-2013-6933

NameCVE-2013-6933
DescriptionThe parseRTSPRequestString function in Live Networks Live555 Streaming Media 2011.08.13 through 2013.11.25, as used in VideoLAN VLC Media Player, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a (1) space or (2) tab character at the beginning of an RTSP message, which triggers an integer underflow, infinite loop, and buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3156-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
liblivemedia (PTS)stretch (security), stretch2016.11.28-1+deb9u2fixed
buster2018.11.26-1.1fixed
mplayer (PTS)stretch2:1.3.0-6fixed
buster2:1.3.0-8fixed
bullseye, sid2:1.4+ds1-1fixed
vlc (PTS)stretch (security), stretch3.0.11-0+deb9u1fixed
buster, buster (security)3.0.12-0+deb10u1fixed
bullseye, sid3.0.12-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
liblivemediasourcesqueeze(not affected)
liblivemediasourcewheezy2012.05.17-1+wheezy1DSA-3156-1
liblivemediasource(unstable)2014.01.13-1
mplayersourcewheezy2:1.0~rc4.dfsg1+svn34540-1+deb7u1DSA-3156-1
mplayersource(unstable)2:1.1.1+svn37434-1low
mplayer2source(unstable)(not affected)
vlcsourcesqueeze(not affected)
vlcsourcewheezy2.0.3-5+deb7u2
vlcsource(unstable)2.1.4-1

Notes

[squeeze] - liblivemedia <not-affected> (vuln. code introduced in 2011.08.13)
[squeeze] - vlc <not-affected> (not built against vuln. liblivemedia)
[squeeze] - mplayer <no-dsa> (Minor issue)
- mplayer2 <not-affected> (b-d's on liblivemedia but doesn't actually build the support for it)
vlc fixed by binNMU 2.1.2-2+b1, but since binNMUs are not visible to the security tracker, the subsequent sid upload is tracked
for wheezy the version present at release of DSA 3156 is used (2.0.3-5+deb7u2), although strictly speaking it's 2.0.3-5+deb7u2+b1

Search for package or bug name: Reporting problems