CVE-2013-7338

NameCVE-2013-7338
DescriptionPython before 3.3.4 RC1 allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via a file size value larger than the size of the zip file to the (1) ZipExtFile.read, (2) ZipExtFile.read(n), (3) ZipExtFile.readlines, (4) ZipFile.extract, or (5) ZipFile.extractall function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python2.7 (PTS)jessie2.7.9-2+deb8u1fixed
jessie (security)2.7.9-2+deb8u4fixed
stretch (security), stretch2.7.13-2+deb9u3fixed
buster2.7.16-2fixed
bullseye, sid2.7.16-4fixed
python3.4 (PTS)jessie3.4.2-1fixed
jessie (security)3.4.2-1+deb8u6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python2.5source(unstable)(not affected)
python2.6source(unstable)(not affected)
python2.7source(unstable)(not affected)
python3.1source(unstable)(unfixed)low
python3.2source(unstable)(unfixed)low
python3.3source(unstable)3.3.4-1low
python3.4source(unstable)3.4~b3-1low

Notes

- python2.5 <not-affected> (Only affects 3.x)
- python2.6 <not-affected> (Only affects 3.x)
- python2.7 <not-affected> (Only affects 3.x)
[squeeze] - python3.1 <no-dsa> (Minor issue)
[wheezy] - python3.2 <no-dsa> (Minor issue)
http://bugs.python.org/issue20078

Search for package or bug name: Reporting problems