CVE-2014-1912

NameCVE-2014-1912
DescriptionBuffer overflow in the socket.recvfrom_into function in Modules/socketmodule.c in Python 2.5 before 2.7.7, 3.x before 3.3.4, and 3.4.x before 3.4rc1 allows remote attackers to execute arbitrary code via a crafted string.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDLA-25-1, DSA-2880-1
NVD severityhigh (attack range: remote)
Debian/oldstablepackages python2.5, python2.6, python3.1 are vulnerable.
Debian/stablepackages python2.6, python3.2 are vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python2.5 (PTS)squeeze2.5.5-11vulnerable
python2.6 (PTS)squeeze2.6.6-8vulnerable
squeeze (lts)2.6.6-8+deb6u3fixed
wheezy2.6.8-1.1vulnerable
python2.7 (PTS)wheezy, wheezy (security)2.7.3-6+deb7u2fixed
jessie2.7.8-11fixed
sid2.7.9-1fixed
python3.1 (PTS)squeeze3.1.3-1vulnerable
python3.2 (PTS)wheezy3.2.3-7vulnerable
python3.4 (PTS)jessie3.4.2-1fixed
sid3.4.2-4fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python2.5source(unstable)(unfixed)low
python2.6source(unstable)(unfixed)low
python2.6sourcesqueeze2.6.6-8+deb6u1highDLA-25-1
python2.7source(unstable)2.7.6-6low
python2.7sourcewheezy2.7.3-6+deb7u2highDSA-2880-1
python3.1source(unstable)(unfixed)low
python3.2source(unstable)(unfixed)low
python3.3source(unstable)3.3.5-1low
python3.4source(unstable)3.4.0-1low

Notes

[squeeze] - python2.5 <no-dsa> (Minor issue)
[wheezy] - python2.6 <no-dsa> (Minor issue)
[squeeze] - python3.1 <no-dsa> (Minor issue)
[wheezy] - python3.2 <no-dsa> (Minor issue)
http://bugs.python.org/issue20246
https://www.trustedsec.com/february-2014/python-remote-code-execution-socket-recvfrom_into/

Search for package or bug name: Reporting problems