CVE-2014-9639

NameCVE-2014-9639
DescriptionInteger overflow in oggenc in vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (crash) via a crafted number of channels in a WAV file, which triggers an out-of-bounds memory access.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1010-1, DLA-317-1
NVD severitymedium (attack range: remote)
Debian Bugs776086, 780160

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
opus-tools (PTS)wheezy0.1.2-1vulnerable
jessie0.1.9-1vulnerable
buster, sid, stretch0.1.10-1fixed
vorbis-tools (PTS)wheezy1.4.0-1vulnerable
wheezy (security)1.4.0-1+deb7u1fixed
jessie1.4.0-6+deb8u1fixed
buster, sid, stretch1.4.0-10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opus-toolssource(unstable)0.1.10-1medium780160
vorbis-toolssource(unstable)1.4.0-7low776086
vorbis-toolssourcejessie1.4.0-6+deb8u1medium
vorbis-toolssourcesqueeze1.4.0-1+deb6u1mediumDLA-317-1
vorbis-toolssourcewheezy1.4.0-1+deb7u1mediumDLA-1010-1

Notes

[squeeze] - vorbis-tools <no-dsa> (Minor issue)
[jessie] - opus-tools <no-dsa> (Minor issue)
[wheezy] - opus-tools <no-dsa> (Minor issue)
https://trac.xiph.org/ticket/2136
Fixed by: https://github.com/mark4o/opus-tools/commit/8c412e619b83eb6dd32191909cf6672e93e5802e
proposed patch: http://lists.xiph.org/pipermail/vorbis-dev/2015-February/020423.html

Search for package or bug name: Reporting problems